<!-- =========================
     Page Breadcrumb   
============================== -->
<!DOCTYPE html>
<html lang="en-US">
<head>
<meta charset="UTF-8">
<meta name="viewport" content="width=device-width, initial-scale=1">
<link rel="profile" href="http://gmpg.org/xfn/11">
<title>Murder suspect turns himself in &#8211; Madison County Courier</title>
<!-- Jetpack Site Verification Tags -->
<meta name="google-site-verification" content="Yla7zNNXak63nDhUyqb27-dcyHM" />
<link rel='dns-prefetch' href='//platform-api.sharethis.com' />
<link rel='dns-prefetch' href='//fonts.googleapis.com' />
<link rel='dns-prefetch' href='//s.w.org' />
<link rel='dns-prefetch' href='//v0.wordpress.com' />
<link rel='dns-prefetch' href='//i0.wp.com' />
<link rel='dns-prefetch' href='//i1.wp.com' />
<link rel='dns-prefetch' href='//i2.wp.com' />
<link rel="alternate" type="application/rss+xml" title="Madison County Courier &raquo; Feed" href="https://madisoncountycourier.com" />
<link rel="alternate" type="application/rss+xml" title="Madison County Courier &raquo; Comments Feed" href="https://madisoncountycourier.com/?feed=comments-rss2" />
<link rel="alternate" type="application/rss+xml" title="Madison County Courier &raquo; Murder suspect turns himself in Comments Feed" href="https://madisoncountycourier.com/?feed=rss2&#038;p=112793" />
<!-- This site uses the Google Analytics by ExactMetrics plugin v6.2.2 - Using Analytics tracking - https://www.exactmetrics.com/ -->
<script type="text/javascript" data-cfasync="false">
	var em_version         = '6.2.2';
	var em_track_user      = true;
	var em_no_track_reason = '';
	
	var disableStr = 'ga-disable-UA-170458762-1';

	/* Function to detect opted out users */
	function __gaTrackerIsOptedOut() {
		return document.cookie.indexOf(disableStr + '=true') > -1;
	}

	/* Disable tracking if the opt-out cookie exists. */
	if ( __gaTrackerIsOptedOut() ) {
		window[disableStr] = true;
	}

	/* Opt-out function */
	function __gaTrackerOptout() {
	  document.cookie = disableStr + '=true; expires=Thu, 31 Dec 2099 23:59:59 UTC; path=/';
	  window[disableStr] = true;
	}

	if ( 'undefined' === typeof gaOptout ) {
		function gaOptout() {
			__gaTrackerOptout();
		}
	}
	
	if ( em_track_user ) {
		(function(i,s,o,g,r,a,m){i['GoogleAnalyticsObject']=r;i[r]=i[r]||function(){
			(i[r].q=i[r].q||[]).push(arguments)},i[r].l=1*new Date();a=s.createElement(o),
			m=s.getElementsByTagName(o)[0];a.async=1;a.src=g;m.parentNode.insertBefore(a,m)
		})(window,document,'script','//www.google-analytics.com/analytics.js','__gaTracker');

window.ga = __gaTracker;		__gaTracker('create', 'UA-170458762-1', 'auto');
		__gaTracker('set', 'forceSSL', true);
		__gaTracker('send','pageview');
		__gaTracker( function() { window.ga = __gaTracker; } );
	} else {
		console.log( "" );
		(function() {
			/* https://developers.google.com/analytics/devguides/collection/analyticsjs/ */
			var noopfn = function() {
				return null;
			};
			var noopnullfn = function() {
				return null;
			};
			var Tracker = function() {
				return null;
			};
			var p = Tracker.prototype;
			p.get = noopfn;
			p.set = noopfn;
			p.send = noopfn;
			var __gaTracker = function() {
				var len = arguments.length;
				if ( len === 0 ) {
					return;
				}
				var f = arguments[len-1];
				if ( typeof f !== 'object' || f === null || typeof f.hitCallback !== 'function' ) {
					console.log( 'Not running function __gaTracker(' + arguments[0] + " ....) because you are not being tracked. " + em_no_track_reason );
					return;
				}
				try {
					f.hitCallback();
				} catch (ex) {

				}
			};
			__gaTracker.create = function() {
				return new Tracker();
			};
			__gaTracker.getByName = noopnullfn;
			__gaTracker.getAll = function() {
				return [];
			};
			__gaTracker.remove = noopfn;
			window['__gaTracker'] = __gaTracker;
			window.ga = __gaTracker;		})();
		}
</script>
<!-- / Google Analytics by ExactMetrics -->
		<script type="text/javascript">
			window._wpemojiSettings = {"baseUrl":"https:\/\/s.w.org\/images\/core\/emoji\/13.0.0\/72x72\/","ext":".png","svgUrl":"https:\/\/s.w.org\/images\/core\/emoji\/13.0.0\/svg\/","svgExt":".svg","source":{"concatemoji":"https:\/\/madisoncountycourier.com\/wp-includes\/js\/wp-emoji-release.min.js?ver=5.5"}};
			!function(e,a,t){var r,n,o,i,p=a.createElement("canvas"),s=p.getContext&&p.getContext("2d");function c(e,t){var a=String.fromCharCode;s.clearRect(0,0,p.width,p.height),s.fillText(a.apply(this,e),0,0);var r=p.toDataURL();return s.clearRect(0,0,p.width,p.height),s.fillText(a.apply(this,t),0,0),r===p.toDataURL()}function l(e){if(!s||!s.fillText)return!1;switch(s.textBaseline="top",s.font="600 32px Arial",e){case"flag":return!c([127987,65039,8205,9895,65039],[127987,65039,8203,9895,65039])&&(!c([55356,56826,55356,56819],[55356,56826,8203,55356,56819])&&!c([55356,57332,56128,56423,56128,56418,56128,56421,56128,56430,56128,56423,56128,56447],[55356,57332,8203,56128,56423,8203,56128,56418,8203,56128,56421,8203,56128,56430,8203,56128,56423,8203,56128,56447]));case"emoji":return!c([55357,56424,8205,55356,57212],[55357,56424,8203,55356,57212])}return!1}function d(e){var t=a.createElement("script");t.src=e,t.defer=t.type="text/javascript",a.getElementsByTagName("head")[0].appendChild(t)}for(i=Array("flag","emoji"),t.supports={everything:!0,everythingExceptFlag:!0},o=0;o<i.length;o++)t.supports[i[o]]=l(i[o]),t.supports.everything=t.supports.everything&&t.supports[i[o]],"flag"!==i[o]&&(t.supports.everythingExceptFlag=t.supports.everythingExceptFlag&&t.supports[i[o]]);t.supports.everythingExceptFlag=t.supports.everythingExceptFlag&&!t.supports.flag,t.DOMReady=!1,t.readyCallback=function(){t.DOMReady=!0},t.supports.everything||(n=function(){t.readyCallback()},a.addEventListener?(a.addEventListener("DOMContentLoaded",n,!1),e.addEventListener("load",n,!1)):(e.attachEvent("onload",n),a.attachEvent("onreadystatechange",function(){"complete"===a.readyState&&t.readyCallback()})),(r=t.source||{}).concatemoji?d(r.concatemoji):r.wpemoji&&r.twemoji&&(d(r.twemoji),d(r.wpemoji)))}(window,document,window._wpemojiSettings);
		</script>
		<style type="text/css">
img.wp-smiley,
img.emoji {
	display: inline !important;
	border: none !important;
	box-shadow: none !important;
	height: 1em !important;
	width: 1em !important;
	margin: 0 .07em !important;
	vertical-align: -0.1em !important;
	background: none !important;
	padding: 0 !important;
}
</style>
	<link rel='stylesheet' id='wp-block-library-css'  href='https://madisoncountycourier.com/wp-includes/css/dist/block-library/style.min.css?ver=5.5' type='text/css' media='all' />
<style id='wp-block-library-inline-css' type='text/css'>
.has-text-align-justify{text-align:justify;}
</style>
<link rel='stylesheet' id='newsup-fonts-css'  href='//fonts.googleapis.com/css?family=Montserrat%3A400%2C500%2C700%2C800%7CWork%2BSans%3A300%2C400%2C500%2C600%2C700%2C800%2C900%26display%3Dswap&#038;subset=latin%2Clatin-ext' type='text/css' media='all' />
<link rel='stylesheet' id='bootstrap-css'  href='https://madisoncountycourier.com/wp-content/themes/newsup/css/bootstrap.css?ver=5.5' type='text/css' media='all' />
<link rel='stylesheet' id='newsup-style-css'  href='https://madisoncountycourier.com/wp-content/themes/newsup/style.css?ver=5.5' type='text/css' media='all' />
<link rel='stylesheet' id='newsup-default-css'  href='https://madisoncountycourier.com/wp-content/themes/newsup/css/colors/default.css?ver=5.5' type='text/css' media='all' />
<link rel='stylesheet' id='font-awesome-css'  href='https://madisoncountycourier.com/wp-content/themes/newsup/css/font-awesome.css?ver=5.5' type='text/css' media='all' />
<link rel='stylesheet' id='owl-carousel-css'  href='https://madisoncountycourier.com/wp-content/themes/newsup/css/owl.carousel.css?ver=5.5' type='text/css' media='all' />
<link rel='stylesheet' id='smartmenus-css'  href='https://madisoncountycourier.com/wp-content/themes/newsup/css/jquery.smartmenus.bootstrap.css?ver=5.5' type='text/css' media='all' />
<link rel='stylesheet' id='social-logos-css'  href='https://madisoncountycourier.com/wp-content/plugins/jetpack/_inc/social-logos/social-logos.min.css?ver=8.8.1' type='text/css' media='all' />
<link rel='stylesheet' id='jetpack_css-css'  href='https://madisoncountycourier.com/wp-content/plugins/jetpack/css/jetpack.css?ver=8.8.1' type='text/css' media='all' />
<script type='text/javascript' src='https://madisoncountycourier.com/wp-includes/js/jquery/jquery.js?ver=1.12.4-wp' id='jquery-js'></script>
<script type='text/javascript' id='jetpack_related-posts-js-extra'>
/* <![CDATA[ */
var related_posts_js_options = {"post_heading":"h4"};
/* ]]> */
</script>
<script type='text/javascript' src='https://madisoncountycourier.com/wp-content/plugins/jetpack/_inc/build/related-posts/related-posts.min.js?ver=20191011' id='jetpack_related-posts-js'></script>
<script type='text/javascript' id='exactmetrics-frontend-script-js-extra'>
/* <![CDATA[ */
var exactmetrics_frontend = {"js_events_tracking":"true","download_extensions":"zip,mp3,mpeg,pdf,docx,pptx,xlsx,rar","inbound_paths":"[{\"path\":\"\\\/go\\\/\",\"label\":\"affiliate\"},{\"path\":\"\\\/recommend\\\/\",\"label\":\"affiliate\"}]","home_url":"https:\/\/madisoncountycourier.com","hash_tracking":"false"};
/* ]]> */
</script>
<script type='text/javascript' src='https://madisoncountycourier.com/wp-content/plugins/google-analytics-dashboard-for-wp/assets/js/frontend.min.js?ver=6.2.2' id='exactmetrics-frontend-script-js'></script>
<script type='text/javascript' src='https://madisoncountycourier.com/wp-content/themes/newsup/js/navigation.js?ver=5.5' id='newsup-navigation-js'></script>
<script type='text/javascript' src='https://madisoncountycourier.com/wp-content/themes/newsup/js/bootstrap.js?ver=5.5' id='bootstrap-js'></script>
<script type='text/javascript' src='https://madisoncountycourier.com/wp-content/themes/newsup/js/owl.carousel.min.js?ver=5.5' id='owl-carousel-min-js'></script>
<script type='text/javascript' src='https://madisoncountycourier.com/wp-content/themes/newsup/js/jquery.smartmenus.js?ver=5.5' id='smartmenus-js-js'></script>
<script type='text/javascript' src='https://madisoncountycourier.com/wp-content/themes/newsup/js/jquery.smartmenus.bootstrap.js?ver=5.5' id='bootstrap-smartmenus-js-js'></script>
<script type='text/javascript' src='https://madisoncountycourier.com/wp-content/themes/newsup/js/jquery.marquee.js?ver=5.5' id='newsup-main-js-js'></script>
<script type='text/javascript' src='//platform-api.sharethis.com/js/sharethis.js#product=ga&#038;property=5ee7dc093a46210012cbbc71' id='googleanalytics-platform-sharethis-js'></script>
<link rel="https://api.w.org/" href="https://madisoncountycourier.com/index.php?rest_route=/" /><link rel="alternate" type="application/json" href="https://madisoncountycourier.com/index.php?rest_route=/wp/v2/posts/112793" /><link rel="EditURI" type="application/rsd+xml" title="RSD" href="https://madisoncountycourier.com/xmlrpc.php?rsd" />
<link rel="wlwmanifest" type="application/wlwmanifest+xml" href="https://madisoncountycourier.com/wp-includes/wlwmanifest.xml" /> 
<link rel='prev' title='Sunrise Movement Hamilton College endorses May for reelection' href='https://madisoncountycourier.com/?p=112789' />
<link rel='next' title='Civil War reenactors to occupy dry docks this weekend' href='https://madisoncountycourier.com/?p=112796' />
<meta name="generator" content="WordPress 5.5" />
<link rel="canonical" href="https://madisoncountycourier.com/?p=112793" />
<link rel='shortlink' href='https://wp.me/p43meu-tlf' />
<link rel="alternate" type="application/json+oembed" href="https://madisoncountycourier.com/index.php?rest_route=%2Foembed%2F1.0%2Fembed&#038;url=https%3A%2F%2Fmadisoncountycourier.com%2F%3Fp%3D112793" />
<link rel="alternate" type="text/xml+oembed" href="https://madisoncountycourier.com/index.php?rest_route=%2Foembed%2F1.0%2Fembed&#038;url=https%3A%2F%2Fmadisoncountycourier.com%2F%3Fp%3D112793&#038;format=xml" />

<!-- This site is using AdRotate v5.8.6.2 to display their advertisements - https://ajdg.solutions/ -->
<!-- AdRotate CSS -->
<style type="text/css" media="screen">
	.g { margin:0px; padding:0px; overflow:hidden; line-height:1; zoom:1; }
	.g img { height:auto; }
	.g-col { position:relative; float:left; }
	.g-col:first-child { margin-left: 0; }
	.g-col:last-child { margin-right: 0; }
	.g-1 { min-width:0px; max-width:300px; }
	.b-1 { margin:3px 0px 0px 0px; }
	.g-2 { margin:0px 0px 0px 0px;width:100%; max-width:1200px; height:100%; max-height:125px; float:left; clear:left; }
	.g-3 { min-width:0px; max-width:300px; }
	.b-3 { margin:3px 0px 0px 0px; }
	@media only screen and (max-width: 480px) {
		.g-col, .g-dyn, .g-single { width:100%; margin-left:0; margin-right:0; }
	}
</style>
<!-- /AdRotate CSS -->

<link rel="pingback" href="https://madisoncountycourier.com/xmlrpc.php"><style type="text/css" id="custom-background-css">
    .wrapper { background-color: #eee; }
</style>
<script>
(function() {
	(function (i, s, o, g, r, a, m) {
		i['GoogleAnalyticsObject'] = r;
		i[r] = i[r] || function () {
				(i[r].q = i[r].q || []).push(arguments)
			}, i[r].l = 1 * new Date();
		a = s.createElement(o),
			m = s.getElementsByTagName(o)[0];
		a.async = 1;
		a.src = g;
		m.parentNode.insertBefore(a, m)
	})(window, document, 'script', 'https://google-analytics.com/analytics.js', 'ga');

	ga('create', 'UA-170458762-1', 'auto');
			ga('send', 'pageview');
	})();
</script>

<!-- Jetpack Open Graph Tags -->
<meta property="og:type" content="article" />
<meta property="og:title" content="Murder suspect turns himself in" />
<meta property="og:url" content="https://madisoncountycourier.com/?p=112793" />
<meta property="og:description" content="The Utica Police Department announced Aug. 12, 2020, the arrest of the suspect in the homicide of Cleastore Jefferson, Justin Peak, who turned himself into police headquarters. “The Utica Police De…" />
<meta property="article:published_time" content="2020-08-13T16:16:00+00:00" />
<meta property="article:modified_time" content="2020-08-13T16:16:00+00:00" />
<meta property="og:site_name" content="Madison County Courier" />
<meta property="og:image" content="https://s0.wp.com/i/blank.jpg" />
<meta property="og:locale" content="en_US" />
<meta name="twitter:creator" content="@marthaeconway" />
<meta name="twitter:site" content="@M3PMedia" />
<meta name="twitter:text:title" content="Murder suspect turns himself in" />
<meta name="twitter:image" content="https://i2.wp.com/madisoncountycourier.com/wp-content/uploads/2019/10/Utica-Police-Department-patch-blotter.jpg?fit=180%2C215&#038;ssl=1&#038;w=144" />
<meta name="twitter:card" content="summary" />

<!-- End Jetpack Open Graph Tags -->
</head>
<body class="post-template-default single single-post postid-112793 single-format-standard wp-embed-responsive  ta-hide-date-author-in-list" >
<div id="page" class="site">
<a class="skip-link screen-reader-text" href="#content">
Skip to content</a>
    <div class="wrapper" id="custom-background-css">
        <header class="mg-headwidget">
            <!--==================== TOP BAR ====================-->

            <div class="mg-head-detail hidden-xs">
    <div class="container-fluid">
        <div class="row">
                        <div class="col-md-6 col-xs-12 col-sm-6">
                <ul class="info-left">
                            <li>Fri. Aug 14th, 2020             <span  id="time" class="time"></span>
                    </li>
                    </ul>
            </div>
                        <div class="col-md-6 col-xs-12">
                <ul class="mg-social info-right">
                    
                                            <li><span class="icon-soci facebook"><a  target="_blank" href="https://www.facebook.com/MadCoCourier/"><i class="fa fa-facebook"></i></a></span> </li>
                                      </ul>
            </div>
                    </div>
    </div>
</div>
            <div class="clearfix"></div>
                        <div class="mg-nav-widget-area-back" style='background-image: url("https://madisoncountycourier.com/wp-content/uploads/2020/06/pool-e1592328596518.jpg" );'>
                        <div class="overlay">
              <div class="inner"  style="background-color:rgba(32,47,91,0.4);" > 
                <div class="container-fluid">
                    <div class="mg-nav-widget-area">
                        <div class="row align-items-center">
                            <div class="col-md-3 col-sm-4 text-center-xs">
                                <div class="navbar-header">
                                                                <div class="site-branding-text">
                                <h1 class="site-title"> <a href="https://madisoncountycourier.com/" rel="home">Madison County Courier</a></h1>
                                <p class="site-description">Your news.  Your voice.</p>
                                </div>
                                                              </div>
                            </div>
                                       <div class="col-md-9 col-sm-8">
                                    <div class="header-ads">
                        <a class="pull-right" href="https://www.madisontourism.com/things-to-do/ask-a-local/form/?utm_source=digital&#038;utm_medium=banner&#038;utm_campaign=local20&#038;utm_content=mcc" 
                            target="_blank"  >
                            <img width="993" height="125" src="https://i1.wp.com/madisoncountycourier.com/wp-content/uploads/2020/07/120-125-2020.jpg?fit=993%2C125&amp;ssl=1" class="attachment-full size-full" alt="" loading="lazy" srcset="https://i1.wp.com/madisoncountycourier.com/wp-content/uploads/2020/07/120-125-2020.jpg?w=993&amp;ssl=1 993w, https://i1.wp.com/madisoncountycourier.com/wp-content/uploads/2020/07/120-125-2020.jpg?resize=300%2C38&amp;ssl=1 300w, https://i1.wp.com/madisoncountycourier.com/wp-content/uploads/2020/07/120-125-2020.jpg?resize=900%2C113&amp;ssl=1 900w, https://i1.wp.com/madisoncountycourier.com/wp-content/uploads/2020/07/120-125-2020.jpg?resize=150%2C19&amp;ssl=1 150w" sizes="(max-width: 993px) 100vw, 993px" />                        </a>
                    </div>
                                

            </div>
            <!-- Trending line END -->
            
                        </div>
                    </div>
                </div>
              </div>
              </div>
          </div>
    <div class="mg-menu-full">
      <nav class="navbar navbar-expand-lg navbar-wp">
        <div class="container-fluid flex-row-reverse">
          <!-- Right nav -->
                    <div class="m-header d-flex pl-3 ml-auto my-2 my-lg-0 position-relative align-items-center">
                                                <a class="mobilehomebtn" href="https://madisoncountycourier.com"><span class="fa fa-home"></span></a>
                        <!-- navbar-toggle -->
                        <button class="navbar-toggler mx-auto" type="button" data-toggle="collapse" data-target="#navbar-wp" aria-controls="navbarSupportedContent" aria-expanded="false" aria-label="Toggle navigation">
                          <i class="fa fa-bars"></i>
                        </button>
                        <!-- /navbar-toggle -->
                        <div class="dropdown show mg-search-box pr-2">
                            <a class="dropdown-toggle msearch ml-auto" href="#" role="button" id="dropdownMenuLink" data-toggle="dropdown" aria-haspopup="true" aria-expanded="false">
                               <i class="fa fa-search"></i>
                            </a>

                            <div class="dropdown-menu searchinner" aria-labelledby="dropdownMenuLink">
                        <form role="search" method="get" id="searchform" action="https://madisoncountycourier.com/">
  <div class="input-group">
    <input type="search" class="form-control" placeholder="Search" value="" name="s" />
    <span class="input-group-btn btn-default">
    <button type="submit" class="btn"> <i class="fa fa-search"></i> </button>
    </span> </div>
</form>                      </div>
                        </div>
                        
                    </div>
                    <!-- /Right nav -->
         
          
                  <div class="collapse navbar-collapse" id="navbar-wp">
                  	<div class="d-md-block">
                  <div class=""><ul class="nav navbar-nav mr-auto"><li ><a href="https://madisoncountycourier.com/" title="Home">Home</a></li><li class="page_item page-item-98600"><a href="https://madisoncountycourier.com/?page_id=98600">Privacy Policy</a></li><li class="page_item page-item-111953"><a href="https://madisoncountycourier.com/?page_id=111953">Want the Morning Rundown?</a></li><li class="page_item page-item-107"><a href="https://madisoncountycourier.com/?page_id=107">About Us</a></li><li class="page_item page-item-109"><a href="https://madisoncountycourier.com/?page_id=109">Advertise With Us</a></li><li class="page_item page-item-111"><a href="https://madisoncountycourier.com/?page_id=111">Contact Us</a></li><li class="page_item page-item-132"><a href="https://madisoncountycourier.com/?page_id=132">Submit Your News</a></li></ul></div>
        				</div>		
              		</div>
          </div>
      </nav> <!-- /Navigation -->
    </div>
</header>
<div class="clearfix"></div>
 <!--==================== Newsup breadcrumb section ====================-->
<!-- =========================
     Page Content Section      
============================== -->
<main id="content">
    <!--container-->
    <div class="container-fluid">
      <!--row-->
      <div class="row">
        <!--col-md-->
                                                <div class="col-md-9">
                    		                  <div class="mg-blog-post-box"> 
              <div class="mg-header">
                                <div class="mg-blog-category"> 
                      <a class="newsup-categories category-color-1" href="https://madisoncountycourier.com/?cat=32" alt="View all posts in Safety/Law Enforcement"> 
                                 Safety/Law Enforcement
                             </a><a class="newsup-categories category-color-1" href="https://madisoncountycourier.com/?cat=8" alt="View all posts in Top Story"> 
                                 Top Story
                             </a>                </div>
                                <h1 class="title single"> <a title="Permalink to: Murder suspect turns himself in">
                  Murder suspect turns himself in</a>
                </h1>

                <div class="media mg-info-author-block"> 
                                    <a class="mg-author-pic" href="https://madisoncountycourier.com/?author=2"> <img alt='' src='https://secure.gravatar.com/avatar/3c637d8015b7578ad20eb280520cb325?s=150&#038;d=mm&#038;r=g' srcset='https://secure.gravatar.com/avatar/3c637d8015b7578ad20eb280520cb325?s=300&#038;d=mm&#038;r=g 2x' class='avatar avatar-150 photo' height='150' width='150' loading='lazy'/> </a>
                                  <div class="media-body">
                                        <h4 class="media-heading"><span>By</span><a href="https://madisoncountycourier.com/?author=2">martha</a></h4>
                                                            <span class="mg-blog-date"><i class="fa fa-clock-o"></i> 
                      Aug 13, 2020</span>
                                        <span class="newsup-tags"><i class="fa fa-tag"></i>
                      <a href="https://madisoncountycourier.com/?p=112793"><a href="https://madisoncountycourier.com/?tag=justin-peak" rel="tag">Justin Peak</a>, <a href="https://madisoncountycourier.com/?tag=murder" rel="tag">murder</a>, <a href="https://madisoncountycourier.com/?tag=sgt-michael-curley" rel="tag">Sgt. Michael Curley</a>, <a href="https://madisoncountycourier.com/?tag=utica-ny-police-department" rel="tag">Utica NY Police Department</a></a>
                    </span>
                                    </div>
                </div>
              </div>
              <img width="180" height="215" src="https://madisoncountycourier.com/wp-content/uploads/2019/10/Utica-Police-Department-patch-blotter.jpg" class="img-responsive wp-post-image" alt="" loading="lazy" srcset="https://i2.wp.com/madisoncountycourier.com/wp-content/uploads/2019/10/Utica-Police-Department-patch-blotter.jpg?w=180&amp;ssl=1 180w, https://i2.wp.com/madisoncountycourier.com/wp-content/uploads/2019/10/Utica-Police-Department-patch-blotter.jpg?resize=126%2C150&amp;ssl=1 126w" sizes="(max-width: 180px) 100vw, 180px" />              <article class="small single">
                
<p>The Utica Police Department announced Aug. 12, 2020, the arrest of the suspect in the homicide of Cleastore Jefferson, Justin Peak, who turned himself into police headquarters.</p>



<p>“The Utica Police Department thanks everyone involved in the apprehension for the hard work throughout the process,” wrote Sgt. Michael Curley in a statement. “This was a team effort extending to the mayor’s office and many different divisions within the police department.</p>



<p>“We would also be remiss if we did not thank the family and attorney of Mr. Peak for assisting us with the peaceful apprehension. Non-traditional methods and cooperation can be the building blocks of police-community relations.</p>



<p>“Hopefully this arrest can bring some peace to the family of Mr. Jefferson.</p>
<div class="sharedaddy sd-sharing-enabled"><div class="robots-nocontent sd-block sd-social sd-social-icon-text sd-sharing"><h3 class="sd-title">Share this:</h3><div class="sd-content"><ul><li class="share-email"><a rel="nofollow noopener noreferrer" data-shared="" class="share-email sd-button share-icon" href="https://madisoncountycourier.com/?p=112793&amp;share=email" target="_blank" title="Click to email this to a friend"><span>Email</span></a></li><li class="share-print"><a rel="nofollow noopener noreferrer" data-shared="" class="share-print sd-button share-icon" href="https://madisoncountycourier.com/?p=112793#print" target="_blank" title="Click to print"><span>Print</span></a></li><li class="share-facebook"><a rel="nofollow noopener noreferrer" data-shared="sharing-facebook-112793" class="share-facebook sd-button share-icon" href="https://madisoncountycourier.com/?p=112793&amp;share=facebook" target="_blank" title="Click to share on Facebook"><span>Facebook</span></a></li><li class="share-twitter"><a rel="nofollow noopener noreferrer" data-shared="sharing-twitter-112793" class="share-twitter sd-button share-icon" href="https://madisoncountycourier.com/?p=112793&amp;share=twitter" target="_blank" title="Click to share on Twitter"><span>Twitter</span></a></li><li class="share-linkedin"><a rel="nofollow noopener noreferrer" data-shared="sharing-linkedin-112793" class="share-linkedin sd-button share-icon" href="https://madisoncountycourier.com/?p=112793&amp;share=linkedin" target="_blank" title="Click to share on LinkedIn"><span>LinkedIn</span></a></li><li class="share-pinterest"><a rel="nofollow noopener noreferrer" data-shared="sharing-pinterest-112793" class="share-pinterest sd-button share-icon" href="https://madisoncountycourier.com/?p=112793&amp;share=pinterest" target="_blank" title="Click to share on Pinterest"><span>Pinterest</span></a></li><li class="share-reddit"><a rel="nofollow noopener noreferrer" data-shared="" class="share-reddit sd-button share-icon" href="https://madisoncountycourier.com/?p=112793&amp;share=reddit" target="_blank" title="Click to share on Reddit"><span>Reddit</span></a></li><li class="share-tumblr"><a rel="nofollow noopener noreferrer" data-shared="" class="share-tumblr sd-button share-icon" href="https://madisoncountycourier.com/?p=112793&amp;share=tumblr" target="_blank" title="Click to share on Tumblr"><span>Tumblr</span></a></li><li class="share-end"></li></ul></div></div></div>
<div id='jp-relatedposts' class='jp-relatedposts' >
	<h3 class="jp-relatedposts-headline"><em>Related</em></h3>
</div>                                                     <script>
    function pinIt()
    {
      var e = document.createElement('script');
      e.setAttribute('type','text/javascript');
      e.setAttribute('charset','UTF-8');
      e.setAttribute('src','https://assets.pinterest.com/js/pinmarklet.js?r='+Math.random()*99999999);
      document.body.appendChild(e);
    }
    </script>
                     <div class="post-share">
                          <div class="post-share-icons cf">
                           
                              <a href="https://www.facebook.com/sharer.php?u=https://madisoncountycourier.com/?p=112793" class="link facebook" target="_blank" >
                                <i class="fa fa-facebook"></i></a>
                            
            
                              <a href="http://twitter.com/share?url=https://madisoncountycourier.com/?p=112793&#038;text=Murder%20suspect%20turns%20himself%20in" class="link twitter" target="_blank">
                                <i class="fa fa-twitter"></i></a>
            
                              <a href="mailto:?subject=Murder%20suspect%20turns%20himself%20in&#038;body=https://madisoncountycourier.com/?p=112793" class="link email" target="_blank" >
                                <i class="fa fa-envelope-o"></i></a>


                              <a href="https://www.linkedin.com/sharing/share-offsite/?url=https://madisoncountycourier.com/?p=112793&#038;title=Murder%20suspect%20turns%20himself%20in" class="link linkedin" target="_blank" >
                                <i class="fa fa-linkedin"></i></a>

                              <a href="javascript:pinIt();" class="link pinterest"><i class="fa fa-pinterest"></i></a>    
                          </div>
                    </div>

              </article>
            </div>
		                 <div class="media mg-info-author-block">
            <a class="mg-author-pic" href="https://madisoncountycourier.com/?author=2"><img alt='' src='https://secure.gravatar.com/avatar/3c637d8015b7578ad20eb280520cb325?s=150&#038;d=mm&#038;r=g' srcset='https://secure.gravatar.com/avatar/3c637d8015b7578ad20eb280520cb325?s=300&#038;d=mm&#038;r=g 2x' class='avatar avatar-150 photo' height='150' width='150' loading='lazy'/></a>
                <div class="media-body">
                  <h4 class="media-heading">By <a href ="https://madisoncountycourier.com/?author=2">martha</a></h4>
                  <p></p>
                </div>
            </div>
                          <div class="mg-featured-slider p-3 mb-4">
                        <!--Start mg-realated-slider -->
                        <div class="mg-sec-title">
                            <!-- mg-sec-title -->
                                                        <h4>Related Post</h4>
                        </div>
                        <!-- // mg-sec-title -->
                           <div class="row">
                                <!-- featured_post -->
                                                                      <!-- blog -->
                                  <div class="col-md-4">
                                    <div class="mg-blog-post-3 minh back-img" 
                                                                        style="background-image: url('https://madisoncountycourier.com/wp-content/uploads/2019/09/USDAFSA.jpg');" >
                                      <div class="mg-blog-inner">
                                                                                      <div class="mg-blog-category"> <a class="newsup-categories category-color-1" href="https://madisoncountycourier.com/?cat=23679" alt="View all posts in Ag, Farming &amp; Gardening"> 
                                 Ag, Farming &amp; Gardening
                             </a><a class="newsup-categories category-color-1" href="https://madisoncountycourier.com/?cat=8" alt="View all posts in Top Story"> 
                                 Top Story
                             </a>                                          </div>                                             <h4 class="title"> <a href="https://madisoncountycourier.com/?p=112806" title="Permalink to: USDA announces help with more commodities eligible for CFAP">
                                              USDA announces help with more commodities eligible for CFAP</a>
                                             </h4>
                                            <div class="mg-blog-meta"> 
                                                                                          <span class="mg-blog-date"><i class="fa fa-clock-o"></i> 
                                              Aug 14, 2020</span>
                                                                                        <a href="https://madisoncountycourier.com/?author=2"> <i class="fa fa-user-circle-o"></i> martha</a>
                                             </div>
                                        </div>
                                    </div>
                                  </div>
                                    <!-- blog -->
                                                                        <!-- blog -->
                                  <div class="col-md-4">
                                    <div class="mg-blog-post-3 minh back-img" 
                                                                        style="background-image: url('https://madisoncountycourier.com/wp-content/uploads/2020/08/Senator-Rachel-May-NY-53SD.jpg');" >
                                      <div class="mg-blog-inner">
                                                                                      <div class="mg-blog-category"> <a class="newsup-categories category-color-1" href="https://madisoncountycourier.com/?cat=3" alt="View all posts in Local"> 
                                 Local
                             </a><a class="newsup-categories category-color-1" href="https://madisoncountycourier.com/?cat=8" alt="View all posts in Top Story"> 
                                 Top Story
                             </a>                                          </div>                                             <h4 class="title"> <a href="https://madisoncountycourier.com/?p=112804" title="Permalink to: Senator Rachel May participates in joint legislative hearing">
                                              Senator Rachel May participates in joint legislative hearing</a>
                                             </h4>
                                            <div class="mg-blog-meta"> 
                                                                                          <span class="mg-blog-date"><i class="fa fa-clock-o"></i> 
                                              Aug 14, 2020</span>
                                                                                        <a href="https://madisoncountycourier.com/?author=2"> <i class="fa fa-user-circle-o"></i> martha</a>
                                             </div>
                                        </div>
                                    </div>
                                  </div>
                                    <!-- blog -->
                                                                        <!-- blog -->
                                  <div class="col-md-4">
                                    <div class="mg-blog-post-3 minh back-img" 
                                                                        style="background-image: url('https://madisoncountycourier.com/wp-content/uploads/2020/08/sediments-scaled.jpg');" >
                                      <div class="mg-blog-inner">
                                                                                      <div class="mg-blog-category"> <a class="newsup-categories category-color-1" href="https://madisoncountycourier.com/?cat=16" alt="View all posts in Arts &amp; Entertainment"> 
                                 Arts &amp; Entertainment
                             </a><a class="newsup-categories category-color-1" href="https://madisoncountycourier.com/?cat=8" alt="View all posts in Top Story"> 
                                 Top Story
                             </a>                                          </div>                                             <h4 class="title"> <a href="https://madisoncountycourier.com/?p=112801" title="Permalink to: 4 Elements Studio presents Kathy Donovan">
                                              4 Elements Studio presents Kathy Donovan</a>
                                             </h4>
                                            <div class="mg-blog-meta"> 
                                                                                          <span class="mg-blog-date"><i class="fa fa-clock-o"></i> 
                                              Aug 14, 2020</span>
                                                                                        <a href="https://madisoncountycourier.com/?author=2"> <i class="fa fa-user-circle-o"></i> martha</a>
                                             </div>
                                        </div>
                                    </div>
                                  </div>
                                    <!-- blog -->
                                                                </div>
                            
                    </div>
                    <!--End mg-realated-slider -->
                  <div id="comments" class="comments-area mg-card-box padding-20">

		<div id="respond" class="comment-respond">
		<h3 id="reply-title" class="comment-reply-title">Leave a Reply <small><a rel="nofollow" id="cancel-comment-reply-link" href="/?p=112793&amp;utm_source=rss&amp;utm_medium=rss&amp;utm_campaign=murder-suspect-turns-himself-in#respond" style="display:none;">Cancel reply</a></small></h3><form action="https://madisoncountycourier.com/wp-comments-post.php" method="post" id="commentform" class="comment-form" novalidate><p class="comment-notes"><span id="email-notes">Your email address will not be published.</span> Required fields are marked <span class="required">*</span></p><p class="comment-form-comment"><label for="comment">Comment</label> <textarea id="comment" name="comment" cols="45" rows="8" maxlength="65525" required="required"></textarea></p><p class="comment-form-author"><label for="author">Name <span class="required">*</span></label> <input id="author" name="author" type="text" value="" size="30" maxlength="245" required='required' /></p>
<p class="comment-form-email"><label for="email">Email <span class="required">*</span></label> <input id="email" name="email" type="email" value="" size="30" maxlength="100" aria-describedby="email-notes" required='required' /></p>
<p class="comment-form-url"><label for="url">Website</label> <input id="url" name="url" type="url" value="" size="30" maxlength="200" /></p>
<p class="form-submit"><input name="submit" type="submit" id="submit" class="submit" value="Post Comment" /> <input type='hidden' name='comment_post_ID' value='112793' id='comment_post_ID' />
<input type='hidden' name='comment_parent' id='comment_parent' value='0' />
</p><p style="display: none;"><input type="hidden" id="akismet_comment_nonce" name="akismet_comment_nonce" value="5f455a2da3" /></p><p style="display: none;"><input type="hidden" id="ak_js" name="ak_js" value="201"/></p></form>	</div><!-- #respond -->
	<p class="akismet_comment_form_privacy_notice">This site uses Akismet to reduce spam. <a href="https://akismet.com/privacy/" target="_blank" rel="nofollow noopener">Learn how your comment data is processed</a>.</p></div><!-- #comments -->      </div>
             <!--sidebar-->
          <!--col-md-3-->
            <aside class="col-md-3">
                  
<aside id="secondary" class="widget-area" role="complementary">
	<div id="sidebar-right" class="mg-sidebar">
		<div id="adrotate_widgets-5" class="mg-widget adrotate_widgets"><div class="g g-3"><div class="g-col b-3 a-85"><a class="gofollow" data-track="ODUsMywxLDEw" href="http://madisoncountycourier.com" target="_blank"><img src="https://i2.wp.com/madisoncountycourier.com/wp-content/uploads/2017/08/linksleadeverywhereupdate.jpg" width="300"></a></div></div><div class="g g-3"><div class="g-col b-3 a-134"><a class="gofollow" data-track="MTM0LDMsMSwxMA==" href="https://www.rushlawberks.com/" target="_blank"><img src="https://i1.wp.com/madisoncountycourier.com/wp-content/uploads/2019/02/Rush-Law-Group-Ad-ALBANY-1.jpg?ssl=1" width="300" /></a></div></div><div class="g g-3"><div class="g-col b-3 a-24"><a class="gofollow" data-track="MjQsMywxLDEw" href="http://logcabinbooks.us" target="_blank"><img src="https://i1.wp.com/madisoncountycourier.com/wp-content/uploads/2015/06/lcbonlinead.full_1.jpg" width="300" /></a>
</div></div><div class="g g-3"><div class="g-col b-3 a-149"><a class="gofollow" data-track="MTQ5LDMsMSwxMA==" href="https://www.madisontourism.com/things-to-do/ask-a-local/form/?utm_source=digital&utm_medium=banner&utm_campaign=local20&utm_content=mcc" target="_blank"><img src="https://i0.wp.com/madisoncountycourier.com/wp-content/uploads/2020/07/MCT_Local_300x300.jpg?ssl=1" width="300"></a>
</div></div></div><div id="archives-3" class="mg-widget widget_archive"><div class="mg-wid-title"><h6>Previously</h6></div>		<label class="screen-reader-text" for="archives-dropdown-3">Previously</label>
		<select id="archives-dropdown-3" name="archive-dropdown">
			
			<option value="">Select Month</option>
				<option value='https://madisoncountycourier.com/?m=202008'> August 2020 &nbsp;(46)</option>
	<option value='https://madisoncountycourier.com/?m=202007'> July 2020 &nbsp;(159)</option>
	<option value='https://madisoncountycourier.com/?m=202006'> June 2020 &nbsp;(117)</option>
	<option value='https://madisoncountycourier.com/?m=202005'> May 2020 &nbsp;(1)</option>
	<option value='https://madisoncountycourier.com/?m=202004'> April 2020 &nbsp;(21)</option>
	<option value='https://madisoncountycourier.com/?m=202003'> March 2020 &nbsp;(77)</option>
	<option value='https://madisoncountycourier.com/?m=202002'> February 2020 &nbsp;(137)</option>
	<option value='https://madisoncountycourier.com/?m=202001'> January 2020 &nbsp;(96)</option>
	<option value='https://madisoncountycourier.com/?m=201912'> December 2019 &nbsp;(127)</option>
	<option value='https://madisoncountycourier.com/?m=201911'> November 2019 &nbsp;(88)</option>
	<option value='https://madisoncountycourier.com/?m=201910'> October 2019 &nbsp;(113)</option>
	<option value='https://madisoncountycourier.com/?m=201909'> September 2019 &nbsp;(101)</option>
	<option value='https://madisoncountycourier.com/?m=201908'> August 2019 &nbsp;(125)</option>
	<option value='https://madisoncountycourier.com/?m=201907'> July 2019 &nbsp;(150)</option>
	<option value='https://madisoncountycourier.com/?m=201906'> June 2019 &nbsp;(122)</option>
	<option value='https://madisoncountycourier.com/?m=201905'> May 2019 &nbsp;(118)</option>
	<option value='https://madisoncountycourier.com/?m=201904'> April 2019 &nbsp;(144)</option>
	<option value='https://madisoncountycourier.com/?m=201903'> March 2019 &nbsp;(111)</option>
	<option value='https://madisoncountycourier.com/?m=201902'> February 2019 &nbsp;(98)</option>
	<option value='https://madisoncountycourier.com/?m=201901'> January 2019 &nbsp;(137)</option>
	<option value='https://madisoncountycourier.com/?m=201812'> December 2018 &nbsp;(111)</option>
	<option value='https://madisoncountycourier.com/?m=201811'> November 2018 &nbsp;(177)</option>
	<option value='https://madisoncountycourier.com/?m=201810'> October 2018 &nbsp;(150)</option>
	<option value='https://madisoncountycourier.com/?m=201809'> September 2018 &nbsp;(106)</option>
	<option value='https://madisoncountycourier.com/?m=201808'> August 2018 &nbsp;(181)</option>
	<option value='https://madisoncountycourier.com/?m=201807'> July 2018 &nbsp;(227)</option>
	<option value='https://madisoncountycourier.com/?m=201806'> June 2018 &nbsp;(205)</option>
	<option value='https://madisoncountycourier.com/?m=201805'> May 2018 &nbsp;(245)</option>
	<option value='https://madisoncountycourier.com/?m=201804'> April 2018 &nbsp;(202)</option>
	<option value='https://madisoncountycourier.com/?m=201803'> March 2018 &nbsp;(258)</option>
	<option value='https://madisoncountycourier.com/?m=201802'> February 2018 &nbsp;(178)</option>
	<option value='https://madisoncountycourier.com/?m=201801'> January 2018 &nbsp;(199)</option>
	<option value='https://madisoncountycourier.com/?m=201712'> December 2017 &nbsp;(279)</option>
	<option value='https://madisoncountycourier.com/?m=201711'> November 2017 &nbsp;(331)</option>
	<option value='https://madisoncountycourier.com/?m=201710'> October 2017 &nbsp;(321)</option>
	<option value='https://madisoncountycourier.com/?m=201709'> September 2017 &nbsp;(305)</option>
	<option value='https://madisoncountycourier.com/?m=201708'> August 2017 &nbsp;(305)</option>
	<option value='https://madisoncountycourier.com/?m=201707'> July 2017 &nbsp;(367)</option>
	<option value='https://madisoncountycourier.com/?m=201706'> June 2017 &nbsp;(345)</option>
	<option value='https://madisoncountycourier.com/?m=201705'> May 2017 &nbsp;(366)</option>
	<option value='https://madisoncountycourier.com/?m=201704'> April 2017 &nbsp;(349)</option>
	<option value='https://madisoncountycourier.com/?m=201703'> March 2017 &nbsp;(372)</option>
	<option value='https://madisoncountycourier.com/?m=201702'> February 2017 &nbsp;(332)</option>
	<option value='https://madisoncountycourier.com/?m=201701'> January 2017 &nbsp;(342)</option>
	<option value='https://madisoncountycourier.com/?m=201612'> December 2016 &nbsp;(285)</option>
	<option value='https://madisoncountycourier.com/?m=201611'> November 2016 &nbsp;(327)</option>
	<option value='https://madisoncountycourier.com/?m=201610'> October 2016 &nbsp;(377)</option>
	<option value='https://madisoncountycourier.com/?m=201609'> September 2016 &nbsp;(381)</option>
	<option value='https://madisoncountycourier.com/?m=201608'> August 2016 &nbsp;(373)</option>
	<option value='https://madisoncountycourier.com/?m=201607'> July 2016 &nbsp;(391)</option>
	<option value='https://madisoncountycourier.com/?m=201606'> June 2016 &nbsp;(403)</option>
	<option value='https://madisoncountycourier.com/?m=201605'> May 2016 &nbsp;(479)</option>
	<option value='https://madisoncountycourier.com/?m=201604'> April 2016 &nbsp;(336)</option>
	<option value='https://madisoncountycourier.com/?m=201603'> March 2016 &nbsp;(258)</option>
	<option value='https://madisoncountycourier.com/?m=201602'> February 2016 &nbsp;(141)</option>
	<option value='https://madisoncountycourier.com/?m=201601'> January 2016 &nbsp;(148)</option>
	<option value='https://madisoncountycourier.com/?m=201512'> December 2015 &nbsp;(124)</option>
	<option value='https://madisoncountycourier.com/?m=201511'> November 2015 &nbsp;(149)</option>
	<option value='https://madisoncountycourier.com/?m=201510'> October 2015 &nbsp;(205)</option>
	<option value='https://madisoncountycourier.com/?m=201509'> September 2015 &nbsp;(114)</option>
	<option value='https://madisoncountycourier.com/?m=201508'> August 2015 &nbsp;(131)</option>
	<option value='https://madisoncountycourier.com/?m=201507'> July 2015 &nbsp;(125)</option>
	<option value='https://madisoncountycourier.com/?m=201506'> June 2015 &nbsp;(170)</option>
	<option value='https://madisoncountycourier.com/?m=201505'> May 2015 &nbsp;(164)</option>
	<option value='https://madisoncountycourier.com/?m=201504'> April 2015 &nbsp;(136)</option>
	<option value='https://madisoncountycourier.com/?m=201503'> March 2015 &nbsp;(152)</option>
	<option value='https://madisoncountycourier.com/?m=201502'> February 2015 &nbsp;(119)</option>
	<option value='https://madisoncountycourier.com/?m=201501'> January 2015 &nbsp;(132)</option>
	<option value='https://madisoncountycourier.com/?m=201412'> December 2014 &nbsp;(151)</option>
	<option value='https://madisoncountycourier.com/?m=201411'> November 2014 &nbsp;(152)</option>
	<option value='https://madisoncountycourier.com/?m=201410'> October 2014 &nbsp;(209)</option>
	<option value='https://madisoncountycourier.com/?m=201409'> September 2014 &nbsp;(172)</option>
	<option value='https://madisoncountycourier.com/?m=201408'> August 2014 &nbsp;(179)</option>
	<option value='https://madisoncountycourier.com/?m=201407'> July 2014 &nbsp;(202)</option>
	<option value='https://madisoncountycourier.com/?m=201406'> June 2014 &nbsp;(199)</option>
	<option value='https://madisoncountycourier.com/?m=201405'> May 2014 &nbsp;(248)</option>
	<option value='https://madisoncountycourier.com/?m=201404'> April 2014 &nbsp;(246)</option>
	<option value='https://madisoncountycourier.com/?m=201403'> March 2014 &nbsp;(217)</option>
	<option value='https://madisoncountycourier.com/?m=201402'> February 2014 &nbsp;(184)</option>
	<option value='https://madisoncountycourier.com/?m=201401'> January 2014 &nbsp;(207)</option>
	<option value='https://madisoncountycourier.com/?m=201312'> December 2013 &nbsp;(205)</option>
	<option value='https://madisoncountycourier.com/?m=201311'> November 2013 &nbsp;(308)</option>
	<option value='https://madisoncountycourier.com/?m=201310'> October 2013 &nbsp;(294)</option>
	<option value='https://madisoncountycourier.com/?m=201309'> September 2013 &nbsp;(286)</option>
	<option value='https://madisoncountycourier.com/?m=201308'> August 2013 &nbsp;(275)</option>
	<option value='https://madisoncountycourier.com/?m=201307'> July 2013 &nbsp;(277)</option>
	<option value='https://madisoncountycourier.com/?m=201306'> June 2013 &nbsp;(319)</option>
	<option value='https://madisoncountycourier.com/?m=201305'> May 2013 &nbsp;(411)</option>
	<option value='https://madisoncountycourier.com/?m=201304'> April 2013 &nbsp;(403)</option>
	<option value='https://madisoncountycourier.com/?m=201303'> March 2013 &nbsp;(432)</option>
	<option value='https://madisoncountycourier.com/?m=201302'> February 2013 &nbsp;(395)</option>
	<option value='https://madisoncountycourier.com/?m=201301'> January 2013 &nbsp;(315)</option>
	<option value='https://madisoncountycourier.com/?m=201212'> December 2012 &nbsp;(347)</option>
	<option value='https://madisoncountycourier.com/?m=201211'> November 2012 &nbsp;(439)</option>
	<option value='https://madisoncountycourier.com/?m=201210'> October 2012 &nbsp;(499)</option>
	<option value='https://madisoncountycourier.com/?m=201209'> September 2012 &nbsp;(474)</option>
	<option value='https://madisoncountycourier.com/?m=201208'> August 2012 &nbsp;(360)</option>
	<option value='https://madisoncountycourier.com/?m=201207'> July 2012 &nbsp;(228)</option>
	<option value='https://madisoncountycourier.com/?m=201206'> June 2012 &nbsp;(252)</option>
	<option value='https://madisoncountycourier.com/?m=201205'> May 2012 &nbsp;(273)</option>
	<option value='https://madisoncountycourier.com/?m=201204'> April 2012 &nbsp;(299)</option>
	<option value='https://madisoncountycourier.com/?m=201203'> March 2012 &nbsp;(286)</option>
	<option value='https://madisoncountycourier.com/?m=201202'> February 2012 &nbsp;(289)</option>
	<option value='https://madisoncountycourier.com/?m=201201'> January 2012 &nbsp;(279)</option>

		</select>

<script type="text/javascript">
/* <![CDATA[ */
(function() {
	var dropdown = document.getElementById( "archives-dropdown-3" );
	function onSelectChange() {
		if ( dropdown.options[ dropdown.selectedIndex ].value !== '' ) {
			document.location.href = this.options[ this.selectedIndex ].value;
		}
	}
	dropdown.onchange = onSelectChange;
})();
/* ]]> */
</script>
			</div>	</div>
</aside><!-- #secondary -->
            </aside>
          <!--/col-md-3-->
      <!--/sidebar-->
          </div>
  </div>
</main>
  <div class="container-fluid mr-bot40 mg-posts-sec-inner">
        <div class="missed-inner">
        <div class="row">
                        <div class="col-md-12">
                <div class="mg-sec-title">
                    <!-- mg-sec-title -->
                    <h4>You May Have Missed</h4>
                </div>
            </div>
                            <!--col-md-3-->
                <div class="col-md-3 col-sm-6 pulse animated">
               <div class="mg-blog-post-3 minh back-img" 
                                                        style="background-image: url('https://madisoncountycourier.com/wp-content/uploads/2019/09/USDAFSA.jpg');" >
                    <div class="mg-blog-inner">
                      <div class="mg-blog-category">
                      <a class="newsup-categories category-color-1" href="https://madisoncountycourier.com/?cat=23679" alt="View all posts in Ag, Farming &amp; Gardening"> 
                                 Ag, Farming &amp; Gardening
                             </a><a class="newsup-categories category-color-1" href="https://madisoncountycourier.com/?cat=8" alt="View all posts in Top Story"> 
                                 Top Story
                             </a>                      </div>
                      <h4 class="title"> <a href="https://madisoncountycourier.com/?p=112806" title="Permalink to: USDA announces help with more commodities eligible for CFAP"> USDA announces help with more commodities eligible for CFAP</a> </h4>
                          <div class="mg-blog-meta">
        <span class="mg-blog-date"><i class="fa fa-clock-o"></i>
         <a href="https://madisoncountycourier.com/?m=202008">
         Aug 14, 2020</a></span>
             </div>
                        </div>
                </div>
            </div>
            <!--/col-md-3-->
                         <!--col-md-3-->
                <div class="col-md-3 col-sm-6 pulse animated">
               <div class="mg-blog-post-3 minh back-img" 
                                                        style="background-image: url('https://madisoncountycourier.com/wp-content/uploads/2020/08/Senator-Rachel-May-NY-53SD.jpg');" >
                    <div class="mg-blog-inner">
                      <div class="mg-blog-category">
                      <a class="newsup-categories category-color-1" href="https://madisoncountycourier.com/?cat=3" alt="View all posts in Local"> 
                                 Local
                             </a><a class="newsup-categories category-color-1" href="https://madisoncountycourier.com/?cat=8" alt="View all posts in Top Story"> 
                                 Top Story
                             </a>                      </div>
                      <h4 class="title"> <a href="https://madisoncountycourier.com/?p=112804" title="Permalink to: Senator Rachel May participates in joint legislative hearing"> Senator Rachel May participates in joint legislative hearing</a> </h4>
                          <div class="mg-blog-meta">
        <span class="mg-blog-date"><i class="fa fa-clock-o"></i>
         <a href="https://madisoncountycourier.com/?m=202008">
         Aug 14, 2020</a></span>
             </div>
                        </div>
                </div>
            </div>
            <!--/col-md-3-->
                         <!--col-md-3-->
                <div class="col-md-3 col-sm-6 pulse animated">
               <div class="mg-blog-post-3 minh back-img" 
                                                        style="background-image: url('https://madisoncountycourier.com/wp-content/uploads/2020/08/sediments-scaled.jpg');" >
                    <div class="mg-blog-inner">
                      <div class="mg-blog-category">
                      <a class="newsup-categories category-color-1" href="https://madisoncountycourier.com/?cat=16" alt="View all posts in Arts &amp; Entertainment"> 
                                 Arts &amp; Entertainment
                             </a><a class="newsup-categories category-color-1" href="https://madisoncountycourier.com/?cat=8" alt="View all posts in Top Story"> 
                                 Top Story
                             </a>                      </div>
                      <h4 class="title"> <a href="https://madisoncountycourier.com/?p=112801" title="Permalink to: 4 Elements Studio presents Kathy Donovan"> 4 Elements Studio presents Kathy Donovan</a> </h4>
                          <div class="mg-blog-meta">
        <span class="mg-blog-date"><i class="fa fa-clock-o"></i>
         <a href="https://madisoncountycourier.com/?m=202008">
         Aug 14, 2020</a></span>
             </div>
                        </div>
                </div>
            </div>
            <!--/col-md-3-->
                         <!--col-md-3-->
                <div class="col-md-3 col-sm-6 pulse animated">
               <div class="mg-blog-post-3 minh back-img" 
                                                        style="background-image: url('https://madisoncountycourier.com/wp-content/uploads/2019/03/Rep-Anthony-Brindisi-Congress.jpg');" >
                    <div class="mg-blog-inner">
                      <div class="mg-blog-category">
                      <a class="newsup-categories category-color-1" href="https://madisoncountycourier.com/?cat=23811" alt="View all posts in National"> 
                                 National
                             </a><a class="newsup-categories category-color-1" href="https://madisoncountycourier.com/?cat=8" alt="View all posts in Top Story"> 
                                 Top Story
                             </a>                      </div>
                      <h4 class="title"> <a href="https://madisoncountycourier.com/?p=112799" title="Permalink to: Brindisi issues statement on Israel-United Arab Emirates peace agreement"> Brindisi issues statement on Israel-United Arab Emirates peace agreement</a> </h4>
                          <div class="mg-blog-meta">
        <span class="mg-blog-date"><i class="fa fa-clock-o"></i>
         <a href="https://madisoncountycourier.com/?m=202008">
         Aug 14, 2020</a></span>
             </div>
                        </div>
                </div>
            </div>
            <!--/col-md-3-->
                     

                </div>
            </div>
        </div>
<!--==================== FOOTER AREA ====================-->
        <footer style="background-image:url('https://madisoncountycourier.com/wp-content/uploads/2020/06/sunrise.jpg');">
             <div class="overlay" style="background-color: rgba(0,0,0,0);">
                <!--Start mg-footer-widget-area-->
                                 <!--End mg-footer-widget-area-->
                <!--Start mg-footer-widget-area-->
                <div class="mg-footer-bottom-area">
                    <div class="container-fluid">
                        <div class="divide-line"></div>
                        <div class="row">
                            <!--col-md-4-->
                            <div class="col-md-6">
                                                             <div class="site-branding-text">
                              <h1 class="site-title"> <a href="https://madisoncountycourier.com/" rel="home">Madison County Courier</a></h1>
                              <p class="site-description">Your news.  Your voice.</p>
                              </div>
                                                          </div>

                             
                            <div class="col-md-6 text-right text-xs">
                                
                            <ul class="mg-social">
                                                                 </ul>


                            </div>
                            <!--/col-md-4-->  
                             
                        </div>
                        <!--/row-->
                    </div>
                    <!--/container-->
                </div>
                <!--End mg-footer-widget-area-->

                <div class="mg-footer-copyright">
                    <div class="container-fluid">
                        <div class="row">
                            <div class="col-md-6 text-xs">
                                <p>
                                <a href="https://wordpress.org/">
								Proudly powered by WordPress								</a>
								<span class="sep"> | </span>
								Theme: Newsup by <a href="https://themeansar.com/" rel="designer">Themeansar</a>.								</p>
                            </div>



                            <div class="col-md-6 text-right text-xs">
                                <div class=""><ul class="info-right"><li ><a href="https://madisoncountycourier.com/" title="Home">Home</a></li><li class="page_item page-item-98600"><a href="https://madisoncountycourier.com/?page_id=98600">Privacy Policy</a></li><li class="page_item page-item-111953"><a href="https://madisoncountycourier.com/?page_id=111953">Want the Morning Rundown?</a></li><li class="page_item page-item-107"><a href="https://madisoncountycourier.com/?page_id=107">About Us</a></li><li class="page_item page-item-109"><a href="https://madisoncountycourier.com/?page_id=109">Advertise With Us</a></li><li class="page_item page-item-111"><a href="https://madisoncountycourier.com/?page_id=111">Contact Us</a></li><li class="page_item page-item-132"><a href="https://madisoncountycourier.com/?page_id=132">Submit Your News</a></li></ul></div>
                            </div>
                        </div>
                    </div>
                </div>
            </div>
            <!--/overlay-->
        </footer>
        <!--/footer-->
    </div>
    <!--/wrapper-->
    <!--Scroll To Top-->
    <a href="#" class="ta_upscr bounceInup animated"><i class="fa fa-angle-up"></i></a>
    <!--/Scroll To Top-->
<!-- /Scroll To Top -->

	<script type="text/javascript">
		window.WPCOM_sharing_counts = {"https:\/\/madisoncountycourier.com\/?p=112793":112793};
	</script>
					<div id="sharing_email" style="display: none;">
		<form action="/?p=112793&#038;utm_source=rss&#038;utm_medium=rss&#038;utm_campaign=murder-suspect-turns-himself-in" method="post">
			<label for="target_email">Send to Email Address</label>
			<input type="email" name="target_email" id="target_email" value="" />

			
				<label for="source_name">Your Name</label>
				<input type="text" name="source_name" id="source_name" value="" />

				<label for="source_email">Your Email Address</label>
				<input type="email" name="source_email" id="source_email" value="" />

						<input type="text" id="jetpack-source_f_name" name="source_f_name" class="input" value="" size="25" autocomplete="off" title="This field is for validation and should not be changed" />
			
			<img style="float: right; display: none" class="loading" src="https://madisoncountycourier.com/wp-content/plugins/jetpack/modules/sharedaddy/images/loading.gif" alt="loading" width="16" height="16" />
			<input type="submit" value="Send Email" class="sharing_send" />
			<a rel="nofollow" href="#cancel" class="sharing_cancel" role="button">Cancel</a>

			<div class="errors errors-1" style="display: none;">
				Post was not sent - check your email addresses!			</div>

			<div class="errors errors-2" style="display: none;">
				Email check failed, please try again			</div>

			<div class="errors errors-3" style="display: none;">
				Sorry, your blog cannot share posts by email.			</div>
		</form>
	</div>
		<script type='text/javascript' src='https://madisoncountycourier.com/wp-content/plugins/jetpack/_inc/build/photon/photon.min.js?ver=20191001' id='jetpack-photon-js'></script>
<script type='text/javascript' id='jshowoff-adrotate-js-extra'>
/* <![CDATA[ */
var impression_object = {"ajax_url":"https:\/\/madisoncountycourier.com\/wp-admin\/admin-ajax.php"};
/* ]]> */
</script>
<script type='text/javascript' src='https://madisoncountycourier.com/wp-content/plugins/adrotate/library/jquery.adrotate.dyngroup.js' id='jshowoff-adrotate-js'></script>
<script type='text/javascript' id='clicktrack-adrotate-js-extra'>
/* <![CDATA[ */
var click_object = {"ajax_url":"https:\/\/madisoncountycourier.com\/wp-admin\/admin-ajax.php"};
/* ]]> */
</script>
<script type='text/javascript' src='https://madisoncountycourier.com/wp-content/plugins/adrotate/library/jquery.adrotate.clicktracker.js' id='clicktrack-adrotate-js'></script>
<script type='text/javascript' src='https://madisoncountycourier.com/wp-includes/js/comment-reply.min.js?ver=5.5' id='comment-reply-js'></script>
<script type='text/javascript' src='https://madisoncountycourier.com/wp-includes/js/wp-embed.min.js?ver=5.5' id='wp-embed-js'></script>
<script async="async" type='text/javascript' src='https://madisoncountycourier.com/wp-content/plugins/akismet/_inc/form.js?ver=4.1.6' id='akismet-form-js'></script>
<script type='text/javascript' src='https://madisoncountycourier.com/wp-content/themes/newsup/js/custom.js?ver=5.5' id='newsup-custom-js'></script>
<script type='text/javascript' id='sharing-js-js-extra'>
/* <![CDATA[ */
var sharing_js_options = {"lang":"en","counts":"1","is_stats_active":"1"};
/* ]]> */
</script>
<script type='text/javascript' src='https://madisoncountycourier.com/wp-content/plugins/jetpack/_inc/build/sharedaddy/sharing.min.js?ver=8.8.1' id='sharing-js-js'></script>
<script type='text/javascript' id='sharing-js-js-after'>
var windowOpen;
			jQuery( document.body ).on( 'click', 'a.share-facebook', function() {
				// If there's another sharing window open, close it.
				if ( 'undefined' !== typeof windowOpen ) {
					windowOpen.close();
				}
				windowOpen = window.open( jQuery( this ).attr( 'href' ), 'wpcomfacebook', 'menubar=1,resizable=1,width=600,height=400' );
				return false;
			});
var windowOpen;
			jQuery( document.body ).on( 'click', 'a.share-twitter', function() {
				// If there's another sharing window open, close it.
				if ( 'undefined' !== typeof windowOpen ) {
					windowOpen.close();
				}
				windowOpen = window.open( jQuery( this ).attr( 'href' ), 'wpcomtwitter', 'menubar=1,resizable=1,width=600,height=350' );
				return false;
			});
var windowOpen;
			jQuery( document.body ).on( 'click', 'a.share-linkedin', function() {
				// If there's another sharing window open, close it.
				if ( 'undefined' !== typeof windowOpen ) {
					windowOpen.close();
				}
				windowOpen = window.open( jQuery( this ).attr( 'href' ), 'wpcomlinkedin', 'menubar=1,resizable=1,width=580,height=450' );
				return false;
			});
var windowOpen;
			jQuery( document.body ).on( 'click', 'a.share-tumblr', function() {
				// If there's another sharing window open, close it.
				if ( 'undefined' !== typeof windowOpen ) {
					windowOpen.close();
				}
				windowOpen = window.open( jQuery( this ).attr( 'href' ), 'wpcomtumblr', 'menubar=1,resizable=1,width=450,height=450' );
				return false;
			});
</script>
	<script>
	/(trident|msie)/i.test(navigator.userAgent)&&document.getElementById&&window.addEventListener&&window.addEventListener("hashchange",function(){var t,e=location.hash.substring(1);/^[A-z0-9_-]+$/.test(e)&&(t=document.getElementById(e))&&(/^(?:a|select|input|button|textarea)$/i.test(t.tagName)||(t.tabIndex=-1),t.focus())},!1);
	</script>
	<!-- AdRotate JS -->
<script type="text/javascript">
jQuery(document).ready(function(){
if(jQuery.fn.gslider) {
	jQuery('.g-2').gslider({ groupid: 2, speed: 6000 });
}
});
</script>
<!-- /AdRotate JS -->

<script type='text/javascript' src='https://stats.wp.com/e-202033.js' async='async' defer='defer'></script>
<script type='text/javascript'>
	_stq = window._stq || [];
	_stq.push([ 'view', {v:'ext',j:'1:8.8.1',blog:'59905794',post:'112793',tz:'-4',srv:'madisoncountycourier.com'} ]);
	_stq.push([ 'clickTrackerInit', '59905794', '112793' ]);
</script>
</body>
</html>